Учебники

jBPM5 – Eclipse Plugin

Ниже приведены предварительные условия для установки плагина jBPM:

  • Java 1.5 (или выше) SE JDK
  • Eclipse 4.2 или любая версия и плагин jBPM

Поскольку jBPM написан на Java, мы расскажем, как добавить нужные плагины в этом разделе. Учитывая максимальное количество пользователей Java, использующих Eclipse, давайте посмотрим, как добавить плагин jBPM в Eclipse.

Загрузите двоичные файлы по следующей ссылке – http://download.jboss.org/drools/release/5.3.0.Final/

Не смущайтесь, увидев Drools здесь. Те же плагины используются для jBPM. Если у вас уже установлен плагин Drools, вы можете пропустить шаги установки.

Скачать бинарные файлы

Распакуйте его на жесткий диск. Затем запустите Eclipse и выберите «Справка» → «Установить новое программное обеспечение».

Установите новое программное обеспечение

Нажмите Добавить репозиторий

Добавить репозиторий

Нажмите кнопку « Локально» и выберите «… / binaries / org.drools.updatesite» (где вы загрузили на свой компьютер)

Доступное программное обеспечение

Выберите Drools и jBPM, а затем нажмите кнопку Далее .

Установить деталь

Снова нажмите « Далее» и выберите «Я принимаю условия лицензионного соглашения», а затем нажмите « Готово» . Начнется установка программного обеспечения –

начинается установка программного обеспечения

После успешной установки вы получите следующее диалоговое окно –

успешная установка

Нажмите Да . Затмение возобновляется. Теперь перейдите в Windows → Настройки → Drools → Узлы потока Drools

Drools Flow Nodes

Если вы видите узлы, как показано на скриншоте выше, это доказывает, что плагины были успешно установлены. Теперь мы готовы написать нашу первую программу jBPM.